Technical Forum

SIMATIC S7-1200

TIA portal 10.5, save uploaded program from S7-1200

Thread Starter: AlecTek   Started: 6/1/2011 12:22 AM   Replies: 3

« Previous thread Next thread »
Page 1 of 1 (4 items)
  6/1/2011, 12:22 AM
Joined 4/5/2011
Last visit: 10/17/2014
Posts: 83
Rating:
Rated: no ratings [0 out of 5 / rated 0 time(s)]. (0) 
Rated: no ratings [0 out of 5 / rated 0 time(s)]. (0) 
We have a system: S7-1200 + KTP600.
 
I already know that I cannot upload HMI, but I can upload S7-1200 program. I create an empty project with a same PLC configuration, I go online and a short time all the program is uploaded under program blocks. However, I saved the project and I open it again, the program blocks are empty, just as the new created one.

Please tell me why this happens and how to save the program?
Top
  6/1/2011, 1:37 AM
Joined 2/27/2011
Last visit: 11/23/2012
Posts: 45
Rating:
Rated: Excellent [4.67 out of 5 / rated 3 time(s)]. (3) 
Rated: Excellent [4.5 out of 5 / rated 2 time(s)]. (2) 
Hello

I caught this in the Step 7 v10.5 manual p.534 hope it helps.

Loading blocks from an accessible deviceRequirement• The accessible devices are displayed. 
See also: Displaying accessible devices (Page 1533)
• The PLC folder in the project contains no data. 

Procedure

To upload blocks from an accessible device to your project, follow these steps:

1. In the project tree, drag the "Program blocks" folder of the accessible device to the "Program blocks"
folder of the PLC in the project.The "Upload preview" dialog box opens. This dialog displays messages and proposes actionsnecessary for uploading. If the PLC folder in the project already contains data, a message informsyou that these data will be replaced.

2. Check the messages and, where necessary, enable the actions in the "Action" column.

3. As soon as uploading becomes possible, the "Upload from device" button is enabled.

4. Click the "Upload from device" button.

Tom




=== Edited by primus 1 @ 6/1/2011 11:05 AM [GMT ] ===


=== Edited by primus 1 @ 6/1/2011 11:03 AM [GMT ] ===


=== Edited by primus 1 @ 6/1/2011 1:38 AM [GMT ] ===


Top
Thank you for this post from:
  6/1/2011, 8:02 PM
Joined 4/5/2011
Last visit: 10/17/2014
Posts: 83
Rating:
Rated: no ratings [0 out of 5 / rated 0 time(s)]. (0) 
Rated: no ratings [0 out of 5 / rated 0 time(s)]. (0) 
Thanks, it works
Best regards



=== Edited by AlecTek @ 6/1/2011 8:02 PM [GMT ] ===


Top
  10/13/2014, 6:31 AM
Joined 11/10/2012
Last visit: 10/13/2014
Posts: 1
Rating:
Rated: no ratings [0 out of 5 / rated 0 time(s)]. (0) 
Rated: no ratings [0 out of 5 / rated 0 time(s)]. (0) 
Yesterday I had the same problem, and your post helped me. But while copying, I found some data missing in the PLC program . Then I had to compare it with the accessible device program and made the required changes. I dont know why !!! If you have any answer, please reply. Thanks...
Top
Page 1 of 1 (4 items)
Actions