Technical Forum

Communication / Networks

PG/PC Interface (s7epatsx.exe)

Thread Starter: Gabriel_Rabelo   Started: 12/15/2009 6:45 PM   Replies: 10

« Previous thread Next thread »
12» Page 1 of 2 (11 items)
  12/15/2009, 6:45 PM
Joined 1/17/2008
Last visit: 1/22/2011
Posts: 42
Rating:
Rated: Outstanding [4 out of 5 / rated 8 time(s)]. (8) 
Rated: no ratings [0 out of 5 / rated 0 time(s)]. (0) 

I´m having a problem when I try to install SimaticNet 2008 HF1 under a HP ProLiant DL380G6 server. In the beginning of NCM installation, it stopped and a window to continue the installation is showed. Here we have two situations:

1) If I just click to continue the installation, it´s aborted and an error message is shown telling that the tasks s7epatsx.exe and s7epatdx.exe are in use by another program, but there isn´t another Siemens program installed in this server.

2) If I go to TaskManager and stop the task s7epatsx.exe, I can then normally continue the installation. After installed, if I try to open the tool "Set PG/PC Interface" (in Control Panel or NCM Manager), it´s shown a error message saying that it´s already in use. Then, I open the Task Manager and s7epatsx is there. After stopping it I can open the Set PG/PC Interface window. Every time I turn the server on, the task s7epatsx.exe is started and never automatically stopped, only manually (via Task Manager).

Can anyone help me?


Regards,

Gabriel L. P. Rabelo
+55 31 8827-7017
glprabelo@gmail.com
Top
  12/16/2009, 3:44 PM
Joined 12/9/2009
Last visit: 10/9/2013
Posts: 152
Rating:
Rated: Excellent [4.45 out of 5 / rated 11 time(s)]. (11) 
Rated: no ratings [0 out of 5 / rated 0 time(s)]. (0) 
Hello,

which windows operation system do you use???? First check the compatibility between SIMATIC NET PC software and operation system.

See:
http://support.automation.siemens.com/WW/view/en/9859007


Rnf:lblSmileyTooltip_candel
Top
  12/16/2009, 5:13 PM
Joined 1/17/2008
Last visit: 1/22/2011
Posts: 42
Rating:
Rated: Outstanding [4 out of 5 / rated 8 time(s)]. (8) 
Rated: no ratings [0 out of 5 / rated 0 time(s)]. (0) 

The OS is Windows Server 2003 R2 SP2 Enterprise Edition. Besides this OS isn´t listed as compatible or not, Siemens Support (from Brazil and Germany) says that it´s compatible. This server has four network adapters, is there any problem with that?
What can cause a task like s7epatsx.exe not to stop and always being running?


Regards,

Gabriel L. P. Rabelo
+55 31 8827-7017
glprabelo@gmail.com
Top
  12/17/2009, 3:53 PM
Joined 12/9/2009
Last visit: 10/9/2013
Posts: 152
Rating:
Rated: Excellent [4.45 out of 5 / rated 11 time(s)]. (11) 
Rated: no ratings [0 out of 5 / rated 0 time(s)]. (0) 
Hello,

SIMATIC NET Edition 2008 HF1 don`t support Server 2003 R2 SP2 Enterprise Edition. Please try to install the SIMATIC NET Software on Standard Server.
If you have the same problem than, I recommand to send a Support Request  to the Hotline.

Support Request


Rnf:lblSmileyTooltip_


Top
  12/17/2009, 3:55 PM
Joined 12/9/2009
Last visit: 10/9/2013
Posts: 152
Rating:
Rated: Excellent [4.45 out of 5 / rated 11 time(s)]. (11) 
Rated: no ratings [0 out of 5 / rated 0 time(s)]. (0) 
Sorry the wrong link... blush


Here comes the right link to

Support Request

Rnf:lblSmileyTooltip_
Top
  3/18/2010, 9:30 PM
Joined 1/17/2008
Last visit: 1/22/2011
Posts: 42
Rating:
Rated: Outstanding [4 out of 5 / rated 8 time(s)]. (8) 
Rated: no ratings [0 out of 5 / rated 0 time(s)]. (0) 
Problem solved!
It was a problem in s7DOS.

Regards,

Gabriel L. P. Rabelo
+55 31 8827-7017
glprabelo@gmail.com
Top
Thank you for this post from:
  3/30/2010, 9:07 AM
Joined 2/21/2008
Last visit: 11/5/2012
Posts: 3
Rating:
Rated: no ratings [0 out of 5 / rated 0 time(s)]. (0) 
Rated: no ratings [0 out of 5 / rated 0 time(s)]. (0) 
Hi

I am also having the same problem, but running on a Windows 2003 Server 2003 R2 SP2 Standard edition which is supported.

I didn't understand the s7dos problem. What do I have to look for ??
Top
  3/30/2010, 7:39 PM
Joined 1/17/2008
Last visit: 1/22/2011
Posts: 42
Rating:
Rated: Outstanding [4 out of 5 / rated 8 time(s)]. (8) 
Rated: Above avarage [3 out of 5 / rated 2 time(s)]. (2) 
Here is the solution for the problem above: grin

The error is caused by a bug in S7DOS.
S7DOS is a component, and cannot be installed separately, but you can install the HF1 of Simatic NET CD 2008 SP2 to solve the problem. 
You can download the SimaticNet 2008 SP2 and it´s HF1 with the following link: SimaticNet 2008 SP2 HF1:
http://support.automation.siemens.com/WW/view/en/12660737

SimaticNet 2008 SP2 must be ordered as told in the following link
http://support.automation.siemens.com/WW/view/en/40862824

Accordingly to Siemens, this correction will be in the next future HF (HF5) for WinCC V7.0 SP1 too. Personally I think it´ll be necessary to make a WinCC7.0 SP2. 

Procedure of installation:
1.     At first you´ll need to install WinCC7.0 SP1 + SimaticNet Package. When a window is prompted to continue with the installation of Simatic NCM, you will need to manually stop the service s7epatsx.exe in Windows Task Manager, then, you can continue with the installation.

2.     Install SimaticNet 2008 SP2 (the one you download through the above link).

3.     Install HF1 for SimaticNet 2008 SP2 (again, the one you download through the above link). 

We have made this procedure here and the server is working well now.If you have any difficult, please don´t hesitate to contact me again. 
I hope that I have helped you. Have a nice day.



=== Edited by O_Moderator @ 4/7/2010 11:18 AM [GMT ] ===
links edited

=== Edited by Gabriel_Rabelo @ 3/30/2010 7:42 PM [GMT ] ===



Regards,

Gabriel L. P. Rabelo
+55 31 8827-7017
glprabelo@gmail.com
Top
Thank you for this post from:
  3/3/2011, 7:57 AM
Joined 2/16/2011
Last visit: 2/12/2014
Posts: 8
Rating:
Rated: no ratings [0 out of 5 / rated 0 time(s)]. (0) 
Rated: no ratings [0 out of 5 / rated 0 time(s)]. (0) 
We have exactly the same problem on platform:
  Microsoft(R) Windows(R) Server 2003, Standard Edition  5.2.3790 Service Pack 2  R2
  ProLiant DL320 G6
After Installing Simatic Net CD2008 SP2 and its HF1 the problem still persists (process hangs and occupy 50% CPU). But we do not need to install WinCC.

Installing WinCC needed to solve the problem?
Top
  3/3/2011, 11:24 AM
Joined 2/16/2011
Last visit: 2/12/2014
Posts: 8
Rating:
Rated: no ratings [0 out of 5 / rated 0 time(s)]. (0) 
Rated: no ratings [0 out of 5 / rated 0 time(s)]. (0) 
Thanks Simens Support Team and Joerg Rennert.

The problem simply solved by using correct HF1:
ftp.sbs.de/CD2008SP2HF1.zip

The HF1 from links listed at top (v7.1.0.1) not valid (not for SP2 i think)



=== Edited by BETEP59 @ 3/3/2011 11:43 AM [GMT ] ===


Top
12» Page 1 of 2 (11 items)
Actions