Technical Forum

Communication / Networks

CP5711 doesn't work with MicroWin and S7-200 (PPI)

Thread Starter: OK2PPP   Started: 3/31/2009 7:03 AM   Replies: 22

« Previous thread Next thread »
123» Page 1 of 3 (23 items)
  3/31/2009, 7:03 AM
Joined 10/2/2006
Last visit: 5/29/2014
Posts: 19
Rating:
Rated: no ratings [0 out of 5 / rated 0 time(s)]. (0) 
Rated: no ratings [0 out of 5 / rated 0 time(s)]. (0) 
Hi everyone,
I have just bought CP5711 and I am a little disappointed. It doesn't work with MicroWin and S7-200 (PPI). Old "PCMCIA" card CP5512 has PPI protocol. And Siemens write: "Functionally compatible with the CP 5512, as well as PC Adapter USB". Mayby problem is in me.?
Any information?
Thanks a lot in advance.
Mirek
Thevia company
 



=== Bearbeitet von Blue Moderator @ 31.03.2009 09:05 [GMT ] ===
splitted and renamed

Top
Thank you for this post from:
  3/31/2009, 9:37 AM
Joined 3/21/2006
Last visit: 11/24/2014
Posts: 9896
Rating:
Rated: Outstanding [3.92 out of 5 / rated 1048 time(s)]. (1048) 
Rated: no ratings [0 out of 5 / rated 0 time(s)]. (0) 
Hello,

CP5711 and Microwin, it's very curious. I suggest you to contact with Siemens Support and ask for any info regards this problem.mad. You can look at this thread about CP5711 discuss: astonished

Hope this will helps.

Best regards

  



=== Edited by UMENCHO @ 3/31/2009 9:49 AM [GMT ] ===
I guess you read carefuly in manual how to make replace from CP 5512 to CP 5711. http://support.automation.siemens.com/WW/view/en/34803449 (page 55)

Top
  4/1/2009, 7:44 AM
Joined 10/2/2006
Last visit: 5/29/2014
Posts: 19
Rating:
Rated: no ratings [0 out of 5 / rated 0 time(s)]. (0) 
Rated: no ratings [0 out of 5 / rated 0 time(s)]. (0) 
Hi, I have done installation according to manual. I tried uninstall SimaticNet, CP5512 and CP5711 and to install all again, but without success. I welcome any suggestion. Thanks, Mirek Thevia Company

Attachment: PG_PC_Interface.JPG  (188 Downloads)

Top
  4/2/2009, 11:14 AM
Joined 2/14/2006
Last visit: 10/16/2014
Posts: 5820
Rating:
Rated: Outstanding [3.96 out of 5 / rated 368 time(s)]. (368) 
Users with special expertise supervising conferences
Rated: no ratings [0 out of 5 / rated 0 time(s)]. (0) 
Dear OK2PPP,

may you tell us what happens if you try to access the S7-200 with the setting for CP5711 (Auto) as you configured it? Do you get an error message? Is it not possible to set the Access Point of Application "Micro/Win" to CP5711 (Auto)?

Just to get an idea what is going wrong with your system... or is it just because you do not see a CP5711 PPI?

Best regards
J_Bell

Top
  4/2/2009, 11:58 AM
Joined 10/2/2006
Last visit: 5/29/2014
Posts: 19
Rating:
Rated: no ratings [0 out of 5 / rated 0 time(s)]. (0) 
Rated: no ratings [0 out of 5 / rated 0 time(s)]. (0) 

Hi,
I tried access the S7-200 with CP5711(Auto), but with error Comunication timeout.
CP5711(Auto) is Profibus or MPI only. When I choose CP5711(Auto), there is info window: "(Automatic parameter assignment of your CP 5711 -MainAdapter for MPI/PROFIBUS networks sending bus parameter message frames)".
I have choice CP5711(Auto), CP5711(FWL), CP5711(MPI) and CP5711(PROFIBUS), but not CP5711(PPI). 
I don't understand of text in manual: "6. Download the CP5512 configuration" on page 55.
Regards,
Mirek
Thevia Company

Top
  4/2/2009, 1:17 PM
Joined 2/14/2006
Last visit: 10/16/2014
Posts: 5820
Rating:
Rated: Outstanding [3.96 out of 5 / rated 368 time(s)]. (368) 
Users with special expertise supervising conferences
Rated: Excellent [5 out of 5 / rated 2 time(s)]. (2) 
Dear Mirek,

well, this is more than strange to me... then, let's try these settings:

Set the Micro / Win Interface to CP5711 (PROFIBUS)
Set the Baud rate to 9.600 kBit/s (if you use 19.200 kBit/s set it to this baud rate)
Set the Bus profile to Standard of even better to Universal DP / FMS
Set the flag for "the only Master on the Bus"

and try it again. It has to work

Best regards

J_Bell
Top
Thank you for this post from:
  4/6/2009, 9:58 AM
Joined 10/2/2006
Last visit: 5/29/2014
Posts: 19
Rating:
Rated: no ratings [0 out of 5 / rated 0 time(s)]. (0) 
Rated: no ratings [0 out of 5 / rated 0 time(s)]. (0) 
Hi,
CP5711 works with S7-200, but not 100%. PG/PC Interface has to be set to MPI (CP5711(MPI)), with an appropriate transfer rate and PG/PC the only master on bus setting. The problem is in a connection with S7-200, it takes up to 1 minute. Every time, when I want to monitor S7-200 (Program Status) or to download, I must wait for the connection. During testing, there was error(s) of CP5711 and I had to Reset an restart CP. I think, Siemens has some bugs in CP5711.
I tried to connect S7-200 with CP5711(Profibus) setting, but without success.
Mirek
Thevia Company 
Top
  4/6/2009, 3:00 PM
Joined 2/14/2006
Last visit: 10/16/2014
Posts: 5820
Rating:
Rated: Outstanding [3.96 out of 5 / rated 368 time(s)]. (368) 
Users with special expertise supervising conferences
Rated: no ratings [0 out of 5 / rated 0 time(s)]. (0) 
Dear Mirek,

this sounds really strange to me... I am sorry. It seems so that the CP does not work with PPI at all. The Problem with MPI is that the CPU has to be set to the Baud rate of at least 19,2 kBit otherwise MPI is not useable either. The default setting for the PPI interface is, as far as I know 9,6 kBit, this is not supported by MPI.

So the Solution with PROFIBUS does not help, as I tested it here I saw the CPU but only as a unknown device. I fear the CP will not help with MicroWin at least not at the default setting of the CPU.

Maybe the PPI Multilink cable USB will do a better job here.

Best regards

J_Bell

Top
  4/7/2009, 10:20 AM
Joined 10/2/2006
Last visit: 5/29/2014
Posts: 19
Rating:
Rated: no ratings [0 out of 5 / rated 0 time(s)]. (0) 
Rated: no ratings [0 out of 5 / rated 0 time(s)]. (0) 
Hi,
I have just received official answer from Siemens:

"The CP5711 is not designed for S7-200. Therefore you have no PPI driver. It may partly work (e.g. with MPI) but I recommend using one of the released cables/CPs for S7-200 You can use the USB/PPI cable, CP5512, CP5611, RS232/PPI cable or PC Adapter USB instead of the CP5711.
Best regards
Your Technical Support for Industry Automation and Drive Technologies [snip ...]
SIEMENS  AG
Industry Sector"

Then, technical info on Siemens web pages:   "Functionally compatible with the CP 5512, as well as PC Adapter USB"   is false and I have to buy USB/PPI cable. Quite expensive job to supercede my old notebook with "PCMCIA" slot with new one with ExpressCard slot.

Mirek
Thevia Company



=== Edited by CS Moderator @ 4/7/2009 5:05 PM [GMT ] ===
deleted personal data of siemens employee

Top
Thank you for this post from:
  4/8/2009, 8:05 AM
Joined 3/21/2006
Last visit: 11/24/2014
Posts: 9896
Rating:
Rated: Outstanding [3.92 out of 5 / rated 1048 time(s)]. (1048) 
Rated: no ratings [0 out of 5 / rated 0 time(s)]. (0) 
Hello

Mirek is right. This story is not correct...
wrote:

It may partly work (e.g. with MPI)...


And from CP5711 details:
wrote:

Application area:

...

- Micro/WIN

...

 

Best regards

 





=== Edited by UMENCHO @ 4/8/2009 8:06 AM [GMT ] ===


Top
123» Page 1 of 3 (23 items)
Actions